温馨提示×

温馨提示×

您好,登录后才能下订单哦!

密码登录×
登录注册×
其他方式登录
点击 登录注册 即表示同意《亿速云用户服务条款》

Minimum Transport Cost (floyd算法)

发布时间:2020-06-29 03:01:07 来源:网络 阅读:397 作者:DawnNext 栏目:web开发

Minimum Transport Cost  Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 
 

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 
 

Output

From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 
 

Sample Input

5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output

From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
# include <stdio.h>
# include <stdlib.h>
#define INF 1 << 20
int dis[10005];
int p[10005][1005];
int map[10005][10005];
int mag[10005];
int n;
void floyd()
{
    int i,j,k;
    for(k=1; k<=n; k++)
    {
        for(i=1;i<=n;i++)
        {
            if( i == k || map[i][k]==-1 ) continue;
            for(j=1;j<=n;j++)
            {
                if( k == j || i == j || map[k][j] == -1 ) continue;
                int t = map[i][k] + map[k][j] + mag[k];
                if(map[i][j] == -1 || map[i][j] > t)
                {
                    map[i][j] = t;
                    p[i][j] = p[i][k];
                }
                else if(map[i][j]==t && p[i][k]<p[i][j])
                {
                    p[i][j]=p[i][k];
                }
            }
        }
    }
}
void pr(int x,int y)
{
 	 printf("Path: %d",x);
    while(p[x][y]!=y)
    {
        printf("-->%d",p[x][y]);
        x=p[x][y];
    }
    printf("-->%d\n",y);
}
int main()
{
 	int kai,jie;
 	while(scanf("%d",&n)!=EOF&&n!=0)
	{
         for(int i=1;i<=n;i++)
		    for(int j=1;j<=n;j++)
		    	{
				 	scanf("%d",&map[i][j]);
				 	p[i][j]=j;	
                }
		 for(int i=1;i<=n;i++)
		 	scanf("%d",&mag[i]);
		 floyd();    		
	     while(scanf("%d%d",&kai,&jie)!=EOF&&kai!=-1&&jie!=-1)
  	     {
		 	 printf("From %d to %d :\n",kai,jie);
             if(kai!=jie)
     	   	 {	 
		 	 		 pr(kai,jie);
		 	 		 printf("Total cost : ");
		 	 		 printf("%d\n",map[kai][jie]);
 			 		 printf("\n");
			 }
			 else 	
			 {
			  		printf("Path: %d\n",kai);
			  		printf("Total cost : ");
	 	 		 	printf("0\n");
 		 			printf("\n");
			 }
		 }		 
    }	
}
向AI问一下细节

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

AI