温馨提示×

如何编译hadoop-eclipse插件

发布时间:2021-11-27 10:19:53 来源:亿速云 阅读:123 作者:小新 栏目:云计算

这篇文章主要介绍了如何编译hadoop-eclipse插件,具有一定借鉴价值,感兴趣的朋友可以参考下,希望大家阅读完这篇文章之后大有收获,下面让小编带着大家一起了解一下。

    1、下载hadoop-2.4 ,这个版本的现在有很多人编译好了放在网上,自行下载吧。
    2、下载安装Ant,到官方网址下载安装即可,当然还需要配置环境变量,如下:

            如何编译hadoop-eclipse插件

        cmd到windows控制台,输入ant -version
        如果出现如下字样,说明安装成功:Apache Ant(TM) version 1.9.4 compiled on April 29 2014
 

      3、下载hadoop2x-eclipse-plugin-master,下载地址为 https://codeload.github.com/winghc/hadoop2x-eclipse-plugin/zip/master,下载后解压到D盘
      4、修改D:\hadoop2x-eclipse-plugin-master\ivy\libraries.properties
            将hadoop.version=2.6.0改为hadoop.version=2.4.0
            将jackson.version=1.9.13改为jackson.version=1.8.8,因为hadoop-2.4中没有1.9.13这个版本的jar包
     5、编译,在windows控制台中进入D:\hadoop2x-eclipse-plugin-maste\contrib\eclipse-plugin目录下,执行如下命令:
 

#这里的eclipse.home指的是你的eclipse安装目录,hadoop.home指的是下载编译好并解压的hadoop目录
ant jar -Dversion=2.4.0 -Declipse.home=D:\开发工具\eclipse-jee-luna-SR2-win32-x86_64\eclipse -Dhadoop.home=D:\hadoop-2.4.0



     6、如果现实build successful则表示编译成功,编译好的文件会在 D:\hadoop2x-eclipse-plugin-maste\build\contrib\eclipse-plugin目录下
     7、如果编译失败,大多数情况都是在 libraries.properties配置了,但是在hadoop目录下没有对应的jar,如果只是版本不对,可以根据hadoop目录下的jar更改 libraries.properties,如果是在 libraries.properties配置了,在 hadoop目录下根本没有相关的jar,就暂时把libraries.properties中配置的这个jar去掉,当然也需要在D:\hadoop2x-eclipse-plugin-master\src\contrib\bulid.xml中删掉对应的配置
     8、将我们编译好的jar 放在eclipse安装目录里面的plugs目录下面,重新启动eclipse
     9、eclipse配置如下
         如何编译hadoop-eclipse插件

           配置的这个目录是hadoop的目录
 

     10、在eclipse中  打开 Window ==> show view ==> other ,在mapreduce tools 里面选中map/reduce loactions    
     11、至此,我们就可以新建mapreduce工程了

感谢你能够认真阅读完这篇文章,希望小编分享的“如何编译hadoop-eclipse插件”这篇文章对大家有帮助,同时也希望大家多多支持亿速云,关注亿速云行业资讯频道,更多相关知识等着你来学习!

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

免费拨打  400 100 2938 免费拨打 400 100 2938
24小时售后技术支持 24小时售后技术支持
返回顶部 返回顶部