OSPF高级配置

发布时间:2020-07-26 00:26:26 来源:51CTO 阅读:1162 作者:macbok 栏目:系统运维

OSPF高级配置

-----------------实验所需要的协议---------------

默认路由协议、静态路由协议、RIP协议、OSPF协议

·

----------------GNS3拓扑的详细配置------------------

1、托出六台路由器,(右击选择Configure,选择Slots添加一个端口NM-1FE-TX,其中R3需要添加2个NM-1FE-TX,点击OK即可)
2、托出四台PC机(VPCS)
3、将R6的图标改为cloud(运营商)
OSPF高级配置

·

-------------------详细操作--------------------

第一、进入端口配置地址

R1详细配置:

R1#conf t
RI#(config)int f0/0
R1#(config-if)ip add 192.168.10.1 255.255.255.0
R1#(config-if)no shut
R1#(config-if)int f0/1
R1#(config-if)ip add 192.168.20.1 255.255.255.0
R1#(config-if)no shut
R1#(config-if)ex
R1#(config)ip router 0.0.0.0 0.0.0.0 192.168.20.2   //在末梢网络配置默认路由并指向下一条地址

·
R2详细配置:

R2#conf t
  R2(config)#int f0/1
  R2(config-if)#ip add 192.168.20.2 255.255.255.0
  R2(config-if)#no shut
  R2(config-if)#ex
  R2(config)#int f0/0
  R2(config-if)#ip add 192.168.30.1 255.255.255.0
  R2(config-if)#no shut
  R2(config-if)#ex
  R2(config)#router ospf 1     (//启用OSPF1进程)                              
  R2(config-router)#router-id 2.2.2.2          (//标注route-id 2.2.2.2)    
  R2(config-router)#network 192.168.30.0 0.0.0.255 area 1        (//在area1种宣告30段落网段)   
  R2(config-router)#ex
  R2(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.1                            
    R2(config)#router ospf 1                                                             (//启用OSPF1进程)
  R2(config-router)#Redistribute connected subnets                     (//注入直连网段20段落)
  R2(config-router)#redistribute static subnets                                (//注入静态网段10段落)
  R2(config-router)#ex

·
R3详细配置:

R3#conf t
R3(config)#int f0/0
R3(config-if)#ip add 192.168.30.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#int f0/1
R3(config-if)#ip add 192.168.40.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#int f1/0
R3(config-if)#ip add 12.0.0.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#int f2/0
R3(config-if)#ip add 192.168.70.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#do show ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.30.2    YES manual up                    up      
FastEthernet0/1            192.168.40.1    YES manual up                    up      
FastEthernet1/0            12.0.0.1        YES manual up                    up      
FastEthernet2/0            192.168.70.1    YES manual up                    up      
R3(config-if)#ex
 R3(config)#ip route 0.0.0.0 0.0.0.0 12.0.0.2                         (//配置默认路由并指向下一跳地址)
R3(config)#router ospf 1                                                        (//启用OSPF1进程)
R3(config-router)#router-id 3.3.3.3                                         (//标注router-id 3.3.3.3)
R3(config-router)#network 192.168.30.0 0.0.0.255 area 1    (//在area1中宣告30段落地址)
R3(config-router)#network 192.168.40.0 0.0.0.255 area 0    (//在area0中宣告40段落地址)
R3(config-router)#network 192.168.70.0 0.0.0.255 area 0    (//在area0中宣告70段落地址)
R3(config-router)#default-information originate                     (//注入外部默认路由)
R3(config-router)#ex

·
R4详细配置:

R4#conf t
 R4(config)#int f0/0
  R4(config-if)#ip add 192.168.40.2 255.255.255.0
  R4(config-if)#no shut
  R4(config-if)#int f0/1
  R4(config-if)#ip add 192.168.50.1 255.255.255.0
  R4(config-if)#no shut
  R4(config-if)#ex
  R4(config-router)#router rip      (//配置rip协议)
    R4(config-router)#ver 2
    R4(config-router)#no atuo-summary
    R4(config-router)#network 192.168.50.0
    R4(config-router)#ex
    R4(config-router)#router ip
    R4(config-router)#redistribute ospf 1 metric 5     (//在OSPF协议中注入进程号和度量值)
    R4(config-router)#ex
    R4(config-router)#router ospf 1                           (//启动OSPF1进程)
    R4(config-router)#router-id 4.4.4.4                      (//标注router-id 4.4.4.4)
    R4(config-router)#network 192.168.40.0 0.0.0.255 area 0
    R4(config-router)#redistribute rip subnets           (//注入rip协议)
        R4(config-router)#ex

·
R5详细配置:

R5#conf t
R5(config)#int f0/0
R5(config)# ip add 192.168.50.2 255.255.255.0 
R5(config)#no shut
R5(config)#int f0/1
R5(config)#ip add 192.168.60.1 255.255.255.0
R5(config-if)#no shut
R5(config-if)#ex                                                      (//配置rip协议)
R5(config-if)#router rip
R5(config-router)#ver 2
R5(config-router)#no antuo-summary
R5(config-router)#network 192.168.50.0
R5(config-router)#network 192.168.60.0
R5(config-router)#ex

·
R6详细配置:

R6#conf t
R6(config)#int f0/0
R6(config-if)#ip add 12.0.0.2 255.255.255.0
R6(config-if)#no shut
R6(config-if)#ex
R6(config)#int f0/1
R6(config-if)#ip add 13.0.0.1 255.255.255.0
R6(config-if)#no shut
R6(config-if)#ex
R6(config)#ip route 192.168.0.0 255.255.255.0 12.0.0.1    (//配置静态路由)

·

第二、进入PC端配置IP地址和网关

1、PC1:192.168.10.2 192.168.10.1
2、PC2:192.168.70.2 192.168.70.1
3、PC3:13.0.0.13 13.0.0.1
4、P4:192.168.60.2 192.169.60.1

第三、进入网络互通性测试
PC1> ip 192.168.10.2 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.2 255.255.255.0 gateway 192.168.10.1

PC1> ping 192.168.70.2
192.168.70.2 icmp_seq=1 timeout
192.168.70.2 icmp_seq=2 timeout
84 bytes from 192.168.70.2 icmp_seq=3 ttl=61 time=93.680 ms
84 bytes from 192.168.70.2 icmp_seq=4 ttl=61 time=93.717 ms
84 bytes from 192.168.70.2 icmp_seq=5 ttl=61 time=93.722 ms

PC1> ping 13.0.0.13
13.0.0.13 icmp_seq=1 timeout
13.0.0.13 icmp_seq=2 timeout
84 bytes from 13.0.0.13 icmp_seq=3 ttl=60 time=124.965 ms
84 bytes from 13.0.0.13 icmp_seq=4 ttl=60 time=124.858 ms
84 bytes from 13.0.0.13 icmp_seq=5 ttl=60 time=125.056 ms

PC1> ping 192.168.60.2
192.168.60.2 icmp_seq=1 timeout
84 bytes from 192.168.60.2 icmp_seq=2 ttl=59 time=156.210 ms
84 bytes from 192.168.60.2 icmp_seq=3 ttl=59 time=157.946 ms
84 bytes from 192.168.60.2 icmp_seq=4 ttl=59 time=166.144 ms
84 bytes from 192.168.60.2 icmp_seq=5 ttl=59 time=156.238 ms

PC1> 

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

免费拨打  400 100 2938 免费拨打 400 100 2938
24小时售后技术支持 24小时售后技术支持
返回顶部 返回顶部