温馨提示×

如何在一台机器上同时安装PHP5.2和PHP5.3

发布时间:2021-11-25 17:51:13 来源:亿速云 阅读:53 作者:小新 栏目:开发技术

小编给大家分享一下如何在一台机器上同时安装PHP5.2和PHP5.3,相信大部分人都还不怎么了解,因此分享这篇文章给大家参考一下,希望大家阅读完这篇文章后大有收获,下面让我们一起去了解一下吧!

测试用的 Linux 是 Fedora 14,初始状态是已经安装有 Apache 2.0.64 和 PHP5.2.6 ,分别安装在如下路径:

/usr/local/apache2

/usr/local/php5

现在要再安装一套 PHP5.3,并且保留原有的 PHP5.2,理想状态是它们可以共用已有的 Apache 2。考虑到 PHP 还有命令行运行的需要,即不经过 Apache 的,这就涉及到系统环境变量,所以先从环境变量入手做好准备。

1. 为方便切换 PHP 版本时不用修改环境变量,我们来做个软链接,这样在切换版本时只要修改一下软链接就行了。

# mkdir -p /usr/php/

# ln -s /usr/local/php5 /usr/php/default

然后加入系统环境变量

# vi /etc/profiles

在文件开头加一行

PHP_HOME=/usr/php/default

再找到 PATH= 那行把 PHP_HOME 加进去,比如

PATH=$JAVA_HOME/bin:$PATH:$PHP_HOME/bin:$MYSQL_HOME/bin

退出命令行窗口重新打开,以使环境变量生效,执行一下

$ php -version

能输出 PHP 5.2.6 (cli) 之类的,说明软链接和环境变量已设置好。

2. 备份 apache 的 PHP5.2 的模块

找到 /usr/local/apache2/modules 下 libphp5.so 文件,这个应该是现有 PHP5.2 安装时编译出的模块,把它换名备份一下,以方便下面我们安装 PHP5.3 时编译生成新的 PHP 模块。

# mv libphp5.so libphp526.so

3. 编译安装 PHP5.3

具体配置可自行选择,只要注意安装路径不同于已有的 PHP5.2 的路径就行,如已有的 PHP5.2 的路径是 /usr/local/php5,那么编译 PHP5.3 时可以

./configure --prefix=/usr/local/php53 --with-apxs2=/usr/local/apache2/bin/apxs

--prefix=/usr/local/php53

表示新的 PHP5.3 安装到 /usr/local/php53 路径下

--with-apxs2=/usr/local/apache2/bin/apxs

表示仍使用现有的 apache2 编译并配置

编译安装完成后,会在 /usr/local/php53 下生成很多文件,并且在 /usr/local/apache2/modules 下生成一个新的 libphp5.so,比较一下文件体积,它比刚才备份的 libphp526.so 体积大不少。

4. 配置 Apache2 使其支持不同版本的 PHP

先停止 apache 服务。

编辑 httpd.conf,找到

LoadModule php5_module        modules/libphp5.so

这行,删掉此行,再加上如下一段

<IfDefine php53>

LoadModule php5_module        modules/libphp5.so

</IfDefine>

<IfDefine php526>

LoadModule php5_module        modules/libphp526.so

</IfDefine>

然后启动 apache 带 -D 参数,如

/usr/local/apache2/bin/apachectl -D php53 -k start

则 Apache 会调用 httpd.conf 中 <IfDefine php53> 这段,加载新生成的 PHP5.3 的 libphp5.so。同理,如果

/usr/local/apache2/bin/apachectl -D php526 -k start

则 Apache 会调用 httpd.conf 中 <IfDefine php526> 这段,加载备份 PHP5.2 的 libphp526.so。

用浏览器打开一个 phpinfo() 信息页看一下 PHP 信息吧,应该能看到不同版本的 PHP 信息了。

5. 更新 PHP 路径的软链接

PHP 还要加装 PHP 的扩展,还得让命令行执行 PHP5.3 的新版本,我们只要更新一下 PHP 路径的软链接就行了。

# rm -f /usr/php/default;

# ln -s /usr/local/php53 /usr/php/default

然后命令行执行

$ php -version

能输出 PHP 5.3.6 (cli) 之类的,说明软链接和环境变量已支持新版本了。

然后再编译安装 PHP 的扩展就可以直接用 phpize 而不用带 PHP5.3 的绝对路径了。

6. 切换 PHP 版本

综合以上操作,如果要 PHP5.3 就让 /usr/php/default 指向 /usr/local/php53,启动 Apache 时用

/usr/local/apache2/bin/apachectl -D php53 -k start

如果要 PHP5.2 就让 /usr/php/default 指向 /usr/local/php5,启动 Apache 时用

/usr/local/apache2/bin/apachectl -D php526  -k start

以上是“如何在一台机器上同时安装PHP5.2和PHP5.3”这篇文章的所有内容,感谢各位的阅读!相信大家都有了一定的了解,希望分享的内容对大家有所帮助,如果还想学习更多知识,欢迎关注亿速云行业资讯频道!

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

php
免费拨打  400 100 2938 免费拨打 400 100 2938
24小时售后技术支持 24小时售后技术支持
返回顶部 返回顶部