温馨提示×

Linux mysql 安装无法启动 /etc 下无 mysql 配置文件问题处理

发布时间:2020-04-23 10:32:22 来源:亿速云 阅读:939 作者:三月 栏目:MySQL数据库

本文主要给大家介绍Linux mysql 安装无法启动 /etc 下无 mysql 配置文件问题处理,希望可以给大家补充和更新些知识,如有其它问题需要了解的可以持续在亿速云行业资讯里面关注我的更新文章的。 

Linux mysql 安装无法启动 /etc 下无 mysql 配置文件,
mysql 无法启动,/var/run/mysqld/mysqld.sock or /temple/mysqld.sock 找不到
需确认 并手动安装下 下列软件包:
libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient18
libnet-daemon-perl libplrpc-perl libterm-readkey-perl mysql-client-5.5
mysql-client-core-5.5 mysql-common mysql-server-5.5 mysql-server-core-5.5
mysql-cmmon 这个软件包是配置/etc/mysql/ 下的配置信息的
mysql 无法启动,/var/run/mysqld/mysqld.sock 找不到:
也可能配置文件/etc/mysql/my.cnf 中:
添加 修改:
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port    = 3306
socket  = /var/run/mysqld/mysqld.sock

mysqld.sock 则会自动生成

:~$ sudo apt-get install mysql-client-5.5 mysql-server-5.5

Linux mysql 安装无法启动 /etc 下无 mysql 配置文件问题处理正在读取软件包列表...    完成
正在分析软件包的依赖关系树
正在读取状态信息...     完成
将会安装下列额外的软件包:
libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient18
libnet-daemon-perl libplrpc-perl libterm-readkey-perl mysql-client-core-5.5
mysql-common mysql-server-core-5.5
建议安装的软件包:
libipc-sharedcache-perl tinyca mailx
下列【新】软件包将被安装【重点】:
libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient18
libnet-daemon-perl libplrpc-perl libterm-readkey-perl mysql-client-5.5
mysql-client-core-5.5 mysql-common mysql-server-5.5 mysql-server-core-5.5
升级了 0 个软件包,新安装了 12 个软件包,要卸载 0 个软件包,有 0 个软件包未被升
级。

看了以上关于Linux mysql 安装无法启动 /etc 下无 mysql 配置文件问题处理,希望能给大家在实际运用中带来一定的帮助。本文由于篇幅有限,难免会有不足和需要补充的地方,如有需要更加专业的解答,可在官网联系我们的24小时售前售后,随时帮您解答问题的。

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

主题地图