双核心网络综合实验

发布时间:2020-07-09 07:40:06 来源:51CTO 阅读:5647 作者:帅宇 栏目:网络安全

【实验名称】双核心网络综合实验

【实验目的】

1、 掌握MSTP部署

2、 掌握VRRP协议配置

3、 掌握MSTP+VRRP的双机热备技术

4、 了解基于内部源的动态NAPT配置方法

5、 掌握动态路由(默认路由分发)或者浮动路由配置技术

【实验拓扑】

 详见附件

【配置要求及配置步骤

1)按照图示完成实验设备连接和地址规划,设备名设置为“组号-设备编号-设备名” (如A1-S3550-1-H1)。

2)二层交换机的VLAN规划:

VL10

VL20

VL30

VL40

F0/5-F0/10

F0/11-F0/15

F0/15-F0/20

F0/21-F0/24

(3)按要求配置交换机VLAN、SVI接口。


前三个是非常基础的配置,这里不再给出!需要注意的是交换机之间互联需要将端口配置为trunk!


(4)按要求配置路由器和三层交换机路由接口,使用ping验证链路联通。

H1

H1(config)#interface f0/4

H1(config-if)#no switchport

H1(config-if)#ip address 172.16.1.2 255.255.255.252

H1(config-if)#no shutdown

H2:

H2(config)#interface f0/4

H2(config-if)#no switchport

H2(config-if)#ip address 172.16.1.6 255.255.255.252

H2(config-if)#no shutdown

R2

R1(config)#interface f1/0

R1(config-if)#ip address 172.16.1.1 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#interface f1/1

R1(config-if)#ip address 172.16.1.5 255.255.255.252

R1(config-if)#no shutdown

5)在四台交换机上部署MSTP协议,要求设置两个实例,实例1关联VL10VL30;实例2关联VL20VL40。要求MST修订号设置为1,名称为组号。要求H1为实例1的根交换机、H2为实例2的根交换机,互为备份。

使用show spanning-tree mst configuration命令查看MST配置信息,使用show spanning-tree mstshow spanning-tree mst interface命令分别查看交换机的MST1MST2以及相应接口的信息验证配置结果。

S1:

开启生成树

S1 (config)#spanning-tree     

 !配置生成树模式为MSTP

S1 (config)#spanning-tree mode mstp    

进入MSTP配置模式 

S1 (config)#spanning-tree mst configuration   

!配置instance 1(实例1)并关联Vlan 10和30  

S1 (config-mst)#instance 1 vlan 10,30   

!配置实例2并关联Vlan 2040 

S1 (config-mst)#instance 2 vlan 20,40   

 !配置域名称   

S1 (config-mst)#name fsy

 !配置版本(修订号)

S1 (config-mst)#revision 1

S2:

S2 (config)#spanning-tree     

S2 (config)#spanning-tree mode mstp    

S2 (config)#spanning-tree mst configuration   

S2 (config-mst)#instance 1 vlan 10,30   

S2 (config-mst)#instance 2 vlan 20,40   

S2 (config-mst)#name fsy

S2 (config-mst)#revision 1

H1:

H1 (config)#spanning-tree     

H1 (config)#spanning-tree mode mstp    

H1 (config)#spanning-tree mst configuration   

H1 (config-mst)#instance 1 vlan 10,30   

H1 (config-mst)#instance 2 vlan 20,40   

H1 (config-mst)#name fsy

H1 (config-mst)#revision 1

!配置交换机H1instance 1中的优先级为4096  ,缺省是32768,值越小越优先成为该instance中的root switch

H1 (config)#spanning-tree mst 1 priority 4096  

H2:

H2 (config)#spanning-tree     

H2 (config)#spanning-tree mode mstp    

H2 (config)#spanning-tree mst configuration   

H2 (config-mst)#instance 1 vlan 10,30   

H2 (config-mst)#instance 2 vlan 20,40   

H2 (config-mst)#name fsy

H2 (config-mst)#revision 1

H2 (config)#spanning-tree mst 2 priority 4096   

(6)在两台三层交换机上部署VRRP协议,各VLAN的网关地址统一使用*.*.*.254。要求VRRP主路由与MSTP根桥保持一致性,使用show vrrp (brief)检查结果。注意新旧版本中的standbyvrrp的使用差别。

H1:

H1(config)# interface vlan 10

!配置VRRP10虚拟路由器IP

H1(config-if)# standby 10 ip 172.16.10.254

!配置VRRP10优先级200

H1(config-if)# standby 10 priority 200

H1(config-if)# exit

H1(config)# interface vlan 20

H1(config-if)# standby 20 ip 172.16.20.254

H1(config-if)# standby 20 priority 100

H1(config-if)# exit

H1(config)# interface vlan 30

H1(config-if)# standby 30 ip 172.16.30.254

H1(config-if)# standby 30 priority 200

H1(config-if)# exit

H1(config)# interface vlan 40

H1(config-if)# standby 40 ip 172.16.40.254

H1(config-if)# standby 40 priority 100

H1(config-if)# exit

H2:

H2(config)# interface vlan 10

H2(config-if)# standby 10 ip 172.16.10.254

H2(config-if)# standby 10 priority 100

H2(config-if)# exit

H2(config)# interface vlan 20

H2(config-if)# standby 20 ip 172.16.20.254

H2(config-if)# standby 20 priority 200

H2(config-if)# exit

H2(config)# interface vlan 30

H2(config-if)# standby 30 ip 172.16.30.254

H2(config-if)# standby 30 priority 100

H2(config-if)# exit

H2(config)# interface vlan 40

H2(config-if)# standby 40 ip 172.16.40.254

H2(config-if)# standby 40 priority 200

H2(config-if)# exit

(7)以路由器回环口模拟运营商接入线路,在路由器和三层交换机上完成路由配置,可使用动态路由或者静态路由加浮动路由解决,注意各三层设备的默认路由如何实现?使用show ip route查看结果。

R1:

R1(config)#interface loopback 1

R1(config-if)#ip address 202.100.1.1 255.255.255.252

R1(config)#router ospf 1

R1(config)#exit

R1(config-router)#network 202.100.1.1 0.0.0.3 area 0

R1(config-router)#network 172.16.1.1 0.0.0.3 area 0

R1(config-router)#network 172.16.1.5 0.0.0.3 area 0

H1:

H1(config)#ip routing 0.0.0.0 0.0.0.0 202.100.1.1

H1(config)#router ospf 1

H1(config-router)#network 172.16.1.2 0.0.0.3 area 0

H1(config-router)#network 172.16.10.0 0.0.0.255 area 0

H1(config-router)#network 172.16.20.0 0.0.0.255 area 0

H1(config-router)#network 172.16.30.0 0.0.0.255 area 0

H1(config-router)#network 172.16.40.0 0.0.0.255 area 0

H2:

H2(config)#ip routing 0.0.0.0 0.0.0.0 202.100.1.1

H2(config)#router ospf 1

H2(config-router)#network 172.16.1.6 0.0.0.3 area 0

H2(config-router)#network 172.16.10.0 0.0.0.255 area 0

H2(config-router)#network 172.16.20.0 0.0.0.255 area 0

H2(config-router)#network 172.16.30.0 0.0.0.255 area 0

H2(config-router)#network 172.16.40.0 0.0.0.255 area 0

8)在路由器上配置基于内部源的动态NAPT,实现VL10VL20VL30用户可以访问互联网。

R1:

R1(config)#access-list 10 permit 172.16.10.0 0.0.0.255

R1(config)#access-list 10 permit 172.16.20.0 0.0.0.255

R1(config)#access-list 10 permit 172.16.30.0 0.0.0.255

R1(config)#ip nat pool fsy 202.100.1.1 202.100.1.1 netmask 255.255.255.252

R1(config)#ip nat inside source list 10 pool fsy overload

R1(config)#ip nat inside source list 20 pool fsy overload

R1(config)#ip nat inside source list 30 pool fsy overload

    R1(config)#interface f1/0

R1(config-if)#ip nat inside

R1(config)#interface f1/1

R1(config-if)#ip nat inside

R1(config)#interface loopback 1

R1(config-if)#ip nat outside

此时,配置完成,可以开始测试!

(因为思科默默器无法实现上述配置,我是在做完实验的基础上总结的,难免有错误,欢迎指正)

           


           欢迎批评指正!

 

 


免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

免费拨打  400 100 2938 免费拨打 400 100 2938
24小时售后技术支持 24小时售后技术支持
返回顶部 返回顶部