温馨提示×

Linux系统中查看weblogic版本命令有哪些

发布时间:2022-01-23 19:33:09 来源:亿速云 阅读:484 作者:小新 栏目:开发技术

这篇文章将为大家详细讲解有关Linux系统中查看weblogic版本命令有哪些,小编觉得挺实用的,因此分享给大家做个参考,希望大家阅读完这篇文章后可以有所收获。

Weblogic10:

第一种:根据registry.xml查看

 # 先进入到weblogic目录下
 [weblogic@app01 soft]$cd weblogic
 # 看一下目录下的文件
 [weblogic@app01 soft]$ls
 domain-registry.xml  logs  modules  ocm.rsp  patch_wls1036   registry.dat  registry.xml  user_projects  utils  wlserver_10.3
 # 查看该目录下的registry.xml
 [weblogic@app01 soft]$cat registry.xml

Linux系统中查看weblogic版本命令有哪些

第二种:通过调用weblogic.jar查看

 # 进入到这个目录 其中wlserver_10.3目录 可能weblogic版本号不同后面的数字也不同
 [weblogic@app01 soft]$cd weblogic/wlserver_10.3/server/lib
 # 通过jar包查看
 [weblogic@app01 soft]$java -cp weblogic.jar weblogic.version
 # 同样的也可以直接的看出版本号

Linux系统中查看weblogic版本命令有哪些

第三种:通过log.txt安装日志文件查看

 # 进入到这个目录
 [weblogic@app01 soft]$cd weblogic/logs
 # 查看log.txt文件 这个文件是weblogic安装的信息也可以看到Weblogic Server的版本号
 [weblogic@app01 soft]$cat log.txt

Linux系统中查看weblogic版本命令有哪些

Weblogic12:

Weblogic12跟Weblogic10的目录有些不同,因此也不能全部照搬Weblogic10的查看方式。

第一种:通过调用weblogic.jar查看

 # 进入到这个目录 weblogic12目录中 这个wlserver后面就没有数字了
 [weblogic@app01 soft]$cd weblogic12/wlserver/server/lib
 # 通过jar包查看  结果这里报了个错
 [weblogic@app01 soft]$java -cp weblogic.jar weblogic.version
 Exception in thread "main" java.lang.UnsupportedClassVersionError: weblogic/version : Unsupported major.minor version 51.0
         at java.lang.ClassLoader.defineClass1(Native Method)
         at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
         at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
         at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
         at java.net.URLClassLoader.defineClass(URLClassLoader.java:305)
         at java.net.URLClassLoader.access$000(URLClassLoader.java:57)
         at java.net.URLClassLoader$1.run(URLClassLoader.java:219)
         at java.security.AccessController.doPrivileged(Native Method)
         at java.net.URLClassLoader.findClass(URLClassLoader.java:212)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:300)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
 Could not find the main class: weblogic.version.  Program will exit.
 # 很明显是jdk版本的问题,weblogic12的话是要求jdk1.8的。低版本JDK运行高版本JDK编译的class类。比如说,报错是51.0,说明项目的JDK版本是JDK 7,使用了低于JDK 7的版本去运行该项目。
 #Version和JDK版本的对应关系:
 # 52.0 -> 8.0
 # 51.0 -> 7.0
 # 50.0 -> 1.6
 # 49.0 -> 1.5
 # 查看一下jdk版本
 [weblogic@app01 soft]$java -version
 # 确实是1.6的所以调用weblogic12的jar包会有问题
 java version "1.6.0-211"
 Java(TM)  SE  Runtime Environment (build 1.6.0_211-b11)
 Java  HotSpot(TM) 64-Bit Server VM (build 20.211-b11, mixed mode)
 # 换了个jdk1.8的用户 或者 直接去jdk1.8的安装目录下 后面就要带上weblogic.jar的绝对路径了
 [weblogic@app01 soft]$ ./java -cp /soft/weblogic12/wlserver/server/lib/weblogic.jar weblogic.version
 # 成功

Linux系统中查看weblogic版本命令有哪些

关于“Linux系统中查看weblogic版本命令有哪些”这篇文章就分享到这里了,希望以上内容可以对大家有一定的帮助,使各位可以学到更多知识,如果觉得文章不错,请把它分享出去让更多的人看到。

推荐内容:linux中如何查看weblogic版本

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

免费拨打  400 100 2938 免费拨打 400 100 2938
24小时售后技术支持 24小时售后技术支持
返回顶部 返回顶部