温馨提示×

cocos2dx-lua在xcode8.3的模拟器上崩溃解决办法

发布时间:2020-07-01 18:37:49 来源:51CTO 阅读:2309 作者:oldseven 栏目:编程语言

错误发生在

lua_open()

里的

LuaStack::init()

原因是,iphone5s以上虚拟机需要x86_64支持

解决办法看:

https://github.com/cocos2d/cocos2d-x-3rd-party-libs-src

clone到本地后

1.

cd cocos2d-x-3rd-party-libs-src/build/

2.

./build.sh -p=ios --libs=luajit
3.生成的ios目录里把 include 和 
prebuilt 目录覆盖到项目里的cocos2dx 目录下的相关目录,

在:cocos2d-x/external/lua/luajit下


编译好的下载地址见:
http://down.51cto.com/data/2336188

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

免费拨打  400 100 2938 免费拨打 400 100 2938
24小时售后技术支持 24小时售后技术支持
返回顶部 返回顶部